关于IPv6 ICMPv6类的MIB

【关于IPv6 ICMPv6类的MIB】本文档讲述了一种Internet社区的Internet标准跟踪协议 , 它需要进一步进行讨论和建议以得到改进 。请参考最新版的”Internet架构委员会正式协议标准”来获得本协议的标准化程度和状态 。本备忘录的发布不受任何限制 。
版权声明
Copyright(C)TheInternetSociety(1998) 。版权所有 。
摘要
这个文档是定义了多种IPv6MIB对象组的一系列文档中的一个 。非凡是在这个文档中定义了它描述了ICMPv6组 。
这个文档定义了用于治理基于IPv6Internet的网络治理协议的治理信息数据库(ManagementInformationBase , 缩写为MIB)的一部分 。
在某种意义上 , 这个文档定义了一个MIB模块 , 它既适用于SNMPv2SMI , 也在语义上和对等体SNMPv1的定义相同 。
1.SNMPv2网络治理框架
SNMPv2网络治理框架目前包括三个主要部分 。它们是:
oSMI , 在RFC1902[1]中描述——用于为治理目的描述和命名对象的机制 。
oMIB-II , STD17 , RFC1213[2]——Internet协议组的治理对象核心集 。
oRFC1157/STD15[4]和RFC1905[5]——定义了两个用于访问治理对象的协议版本 。
框架答应出于实验和评估目的来定义新对象 。
1.1.对象定义
治理对象通过一个称为治理信息库或MIB的虚拟信息库来访问 。MIB中的对象用抽象语法标记(ASN.1)的子集(定义在SMI中)定义 。非凡地 , 每个对象类型命名为一个对象标识符(OBJECTIDENTIFIER)(一个治理指配名) 。对象类型和对象实例一起唯一地标识一个特定的实例化对象 。为方便起见 , 通常使用一个文本字符串 , 称为描述符 , 指向对象类型 。
2.综述
这个文档是定义了多种IPv6MIB对象组的一系列文档中的一个 。非凡是在这个文档中定义了它描述了ICMPv6组 。这些组是一致的基本单位:假如把组的语义应用于应用程序 , 那么必须在组中执行所有对象 。例如 , 假如它在IPv6协议上执行TCP的话 , 应用程序必须执行TCP组 。最少 , 应用程序必须执行和在这个文档中定义的ICMPv6组以及IPv6通用组(Generalgroup)[9] 。
这个文档定义了IPv6MIB的ICMPv6组 。
3.ICMPv6类
IPV6-ICMP-MIBDEFINITIONS::=BEGIN
IMPORTS
模块标识符 , 对象类 ,
来自SNMPv2-SMI的mib-2 , 32位计数器
来自SNMPv2-CONF的对象组模块依从关系
来自IPV6-MIB的ipv6IfEntry;
ipv6IcmpMIB模块标识符
最新的更新“9801082155Z”
组织“IETFIPv6WorkingGroup”
联系信息
“DimitryHaSKIN
Postal:BayNetworks , Inc.
660TechologyParkDrive.
Billerica , MA01821
US
Tel: 1-978-916-8124
E-mail:dhaskin@baynetworks.com
SteveOnishi
Postal:BayNetworks , Inc.
3FederalStreet
Billerica , MA01821
US
Tel: 1-978-916-3816
E-mail:sonishi@baynetworks.com”
描述
“执行ICMPv6实体的MIB模块 。”
::={mib-256}
--ICMPv6组
ipv6IcmpMIBObjects对象标识符::={ipv6IcmpMIB1}
--各个接口的ICMPv6状态表
ipv6IfIcmpTable对象类
语法:Ipv6IfIcmpEntry的序列
最大访问权限:不可访问
状态:现行
描述
“IPv6ICMP的统计 。这个表包含了实体收到和发出的ICMPv6消息的统计 。”
::={ipv6IcmpMIBObjects1}
ipv6IfIcmpEntry对象类
语法:Ipv6IfIcmpEntry
最大访问权限:不可访问
状态:现行
描述
“一个ICMPv6统计表项 , 包含着在一个真正的IPv6接口上的对象 。注重:接收接口是给定ICMPv6消息编址的接口 , 对于消息的输入接口不一定必须 。同样地 , 发送接口是源于给定的ICMP消息的接口 , 这个消息一般有输出接口 , 但是这不是必须的 。”
增量{ipv6IfEntry}
::={ipv6IfIcmpTable1}
Ipv6IfIcmpEntry::=序列{
ipv6IfIcmpInMsgs
32位计数器 ,
ipv6IfIcmpInErrors
32位计数器 ,
ipv6IfIcmpInDestUnreachs
32位计数器 ,
ipv6IfIcmpInAdminProhibs
32位计数器 ,
ipv6IfIcmpInTimeExcds
32位计数器 ,
ipv6IfIcmpInParmProblems
32位计数器 ,
ipv6IfIcmpInPktTooBigs
32位计数器 ,
ipv6IfIcmpInEchos
32位计数器 ,
ipv6IfIcmpInEchoReplies
32位计数器 ,
ipv6IfIcmpInRouterSolicits
32位计数器 ,
ipv6IfIcmpInRouterAdvertisements
32位计数器 ,
ipv6IfIcmpInNeighborSolicits
32位计数器 ,
ipv6IfIcmpInNeighborAdvertisements
32位计数器 ,
ipv6IfIcmpInRedirects
32位计数器 ,
ipv6IfIcmpInGroupMembQueries
32位计数器 ,
ipv6IfIcmpInGroupMembResponses
32位计数器 ,
ipv6IfIcmpInGroupMembRedUCtions
32位计数器 ,
ipv6IfIcmpOutMsgs
32位计数器 ,
ipv6IfIcmpOutErrors
32位计数器 ,
ipv6IfIcmpOutDestUnreachs
32位计数器 ,
ipv6IfIcmpOutAdminProhibs
32位计数器 ,
ipv6IfIcmpOutTimeExcds
32位计数器 ,
ipv6IfIcmpOutParmProblems
32位计数器 ,
ipv6IfIcmpOutPktTooBigs
32位计数器 ,
ipv6IfIcmpOutEchos
32位计数器 ,
ipv6IfIcmpOutEchoReplies
32位计数器 ,
ipv6IfIcmpOutRouterSolicits
32位计数器 ,
ipv6IfIcmpOutRouterAdvertisements
32位计数器 ,
ipv6IfIcmpOutNeighborSolicits
32位计数器 ,
ipv6IfIcmpOutNeighborAdvertisements
32位计数器 ,
ipv6IfIcmpOutRedirects
32位计数器 ,
ipv6IfIcmpOutGroupMembQueries
32位计数器 ,
ipv6IfIcmpOutGroupMembResponses
32位计数器 ,
ipv6IfIcmpOutGroupMembReductions
32位计数器
}
ipv6IfIcmpInMsgs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP消息的总数 , 包括由ipv6IfIcmpInErrors累计的所有数字 。注重:这个接口是对ICMP消息编址的接口 , 对于这个消息 , 输入接口不是必须的 。”
::={ipv6IfIcmpEntry1}
ipv6IfIcmpInErrors对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到并检测到带有特定的ICMP错误(ICMP校验错、长度错误等等)的ICMP消息的数量 。”
::={ipv6IfIcmpEntry2}
ipv6IfIcmpInDestUnreachs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口上收到的目的地址不可达的ICMP消息(DestinationUnreachablemessage)的数量 。”
::={ipv6IfIcmpEntry3}
ipv6IfIcmpInAdminProhibs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP源地址不可达/通讯治理禁止(destinationunreachable/communicationadministrativelyprohibited)消息的数量 。”
::={ipv6IfIcmpEntry4}
ipv6IfIcmpInTimeExcds对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP超时(TimeExceeded)消息的数量 。”
::={ipv6IfIcmpEntry5}
ipv6IfIcmpInParmProblems对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP参数问题(ParameterProblem)消息的数量 。”
::={ipv6IfIcmpEntry6}
ipv6IfIcmpInPktTooBigs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP数据包太大(PacketTooBig)消息的数量 。”
::={ipv6IfIcmpEntry7}
ipv6IfIcmpInEchos对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMPEcho(必要的)消息的数量 。”
::={ipv6IfIcmpEntry8}
ipv6IfIcmpInEchoReplies对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMPEcho应答(EchoReply)消息的数量 。”
::={ipv6IfIcmpEntry9}
ipv6IfIcmpInRouterSolicits对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP路由器请求(RouterSolicit)消息的数量 。”
::={ipv6IfIcmpEntry10}
ipv6IfIcmpInRouterAdvertisements对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP路由器通告(RouterAdvertisement)消息的数量 。”
::={ipv6IfIcmpEntry11}
ipv6IfIcmpInNeighborSolicits对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP相邻节点请求(NeighborSolicit)消息的数量 。”
::={ipv6IfIcmpEntry12}
ipv6IfIcmpInNeighborAdvertisements对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMP相邻节点通告(NeighborAdvertisement)消息的数量 。”
::={ipv6IfIcmpEntry13}
ipv6IfIcmpInRedirects对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的重定向(Redirect)消息的数量 。”
::={ipv6IfIcmpEntry14}
ipv6IfIcmpInGroupMembQueries对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMPv6组成员查询(GroupMembershipQuery)消息的数量 。”
::={ipv6IfIcmpEntry15}
ipv6IfIcmpInGroupMembResponses对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMPv6组成员响应(GroupMembershipResponse)消息的数量 。”
::={ipv6IfIcmpEntry16}
ipv6IfIcmpInGroupMembReductions对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口收到的ICMPv6组成员还原(GroupMembershipReduction)消息的数量 。”
::={ipv6IfIcmpEntry17}
ipv6IfIcmpOutMsgs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“这个接口尝试发送的ICMP消息的总数 。注重这个累计数字包含了所有由icmpOutErrors累计的次数 。”
::={ipv6IfIcmpEntry18}
ipv6IfIcmpOutErrors对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“由于在ICMP中发现了诸如缓存缺乏导致的问题而不能发送的ICMP消息的数量 。这个数值不包括在ICMP层之外发现的错误 , 例如IPv6路由失效而产生的数据报 。在某些应用程序中 , 可能有一些形成计数器数值的错误类型 。”
::={ipv6IfIcmpEntry19}
ipv6IfIcmpOutDestUnreachs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP目的地址不可达(DestinationUnreachable)消息的数量 。”
::={ipv6IfIcmpEntry20}
ipv6IfIcmpOutAdminProhibs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“发送的ICMP源地址不可达/通讯治理禁止(destunreachable/communicationadministrativelyprohibited)消息的数量 。”
::={ipv6IfIcmpEntry21}
ipv6IfIcmpOutTimeExcds对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP超时(TimeExceeded)消息的数量 。”
::={ipv6IfIcmpEntry22}
ipv6IfIcmpOutParmProblems对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP参数问题(ParameterProblem)消息的数量 。”
::={ipv6IfIcmpEntry23}
ipv6IfIcmpOutPktTooBigs对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP数据包太大(PacketTooBig)消息的数量 。”
::={ipv6IfIcmpEntry24}
ipv6IfIcmpOutEchos对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMPEcho(请求)消息的数量 。”
::={ipv6IfIcmpEntry25}
ipv6IfIcmpOutEchoReplies对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMPEcho应答消息的数量 。”
::={ipv6IfIcmpEntry26}
ipv6IfIcmpOutRouterSolicits对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP路由器请求消息的数量 。”
::={ipv6IfIcmpEntry27}
ipv6IfIcmpOutRouterAdvertisements对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP路由器通告消息的数量 。”
::={ipv6IfIcmpEntry28}
ipv6IfIcmpOutNeighborSolicits对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP相邻节点请求消息的数量 。”
::={ipv6IfIcmpEntry29}
ipv6IfIcmpOutNeighborAdvertisements对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“接口发送的ICMP相邻节点(NeighborAdvertisement)消息的数量 。”
::={ipv6IfIcmpEntry30}
ipv6IfIcmpOutRedirects对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“发送的重定向消息的数量 。对于主机来讲 , 这个对象总是0 , 因为主机不发送重定向 。”
::={ipv6IfIcmpEntry31}
ipv6IfIcmpOutGroupMembQueries对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“发送的ICMPv6组成员查询(GroupMembershipQuery)的数量 。”
::={ipv6IfIcmpEntry32}
ipv6IfIcmpOutGroupMembResponses对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“发送的ICMPv6组成员响应(GroupMembershipResponse)的数量 。”
::={ipv6IfIcmpEntry33}
ipv6IfIcmpOutGroupMembReductions对象类
语法:32位计数器
最大访问权限:只读
状态:现行
描述
“发送的ICMPv6组成员复位(GroupMembershipReduction)的数量 。”
::={ipv6IfIcmpEntry34}
--一致性消息
ipv6IcmpConformance对象标识符::={ipv6IcmpMIB2}
ipv6IcmpCompliances
对象标识符::={ipv6IcmpConformance1}
ipv6IcmpGroups
对象标识符::={ipv6IcmpConformance2}
--依从关系声明
ipv6IcmpCompliance模块依从关系
状态:现行
描述
“执行ICMPv6的SNMPv2实体的依从关系声明 。”
MODULE--thismodule
强制性组{ipv6IcmpGroup}
::={ipv6IcmpCompliances1}
ipv6IcmpGroup对象类
对象{
ipv6IfIcmpInMsgs ,
ipv6IfIcmpInErrors ,
ipv6IfIcmpInDestUnreachs ,
ipv6IfIcmpInAdminProhibs ,
ipv6IfIcmpInTimeExcds ,
ipv6IfIcmpInParmProblems ,
ipv6IfIcmpInPktTooBigs ,
ipv6IfIcmpInEchos ,
ipv6IfIcmpInEchoReplies ,
ipv6IfIcmpInRouterSolicits ,
ipv6IfIcmpInRouterAdvertisements ,
ipv6IfIcmpInNeighborSolicits ,
ipv6IfIcmpInNeighborAdvertisements ,
ipv6IfIcmpInRedirects ,
ipv6IfIcmpInGroupMembQueries ,
ipv6IfIcmpInGroupMembResponses ,
ipv6IfIcmpInGroupMembReductions ,
ipv6IfIcmpOutMsgs ,
ipv6IfIcmpOutErrors ,
ipv6IfIcmpOutDestUnreachs ,
ipv6IfIcmpOutAdminProhibs ,
ipv6IfIcmpOutTimeExcds ,
ipv6IfIcmpOutParmProblems ,
ipv6IfIcmpOutPktTooBigs ,
ipv6IfIcmpOutEchos ,
ipv6IfIcmpOutEchoReplies ,
ipv6IfIcmpOutRouterSolicits ,
ipv6IfIcmpOutRouterAdvertisements ,
ipv6IfIcmpOutNeighborSolicits ,
ipv6IfIcmpOutNeighborAdvertisements ,
ipv6IfIcmpOutRedirects ,
ipv6IfIcmpOutGroupMembQueries ,
ipv6IfIcmpOutGroupMembResponses ,
ipv6IfIcmpOutGroupMembReductions
}
状态:现行
描述
“提供消息细节给ICMPv6的对象的ICMPv6组 。”
::={ipv6IcmpGroups1}
END
4.致谢
这个文档取材于IETF在基于IPv4的Internet方面的MIB作品 。
我们对下列朋友的建设性的和有价值的建议:
MikeDaniele ,
MargaretForsythe ,
Jean-PierreRoch ,
JuergenSchoenwaelder ,
VivekVenkatraman.
5.参考文献
[1]SNMPv2WorkingGroup , Case , J. , McCloghrie , K. , Rose , M. , andS.Waldbusser , “StructureofManagementInformationforVersion2oftheSimpleNetworkManagementProtocol(SNMPv2)” , RFC1902 , January1996 。
[2]SNMPv2WorkingGroup , Case , J. , McCloghrie , K. , Rose , M. , andS.Waldbusser , “TextualConventionsforVersion2oftheSimpleNetworkManagementProtocol(SNMPv2)” , RFC1903 , January1996 。
[3]McCloghrie , K. , andM.Rose , Editors , “ManagementInformationBaseforNetworkManagementofTCP/IP-basedinternets:MIB-II” , STD17 , RFC1213 , March1991 。
[4]Case , J. , Fedor , M. , Schoffstall , M.andJ.Davin , “ASimpleNetworkManagementProtocol(SNMP)” , STD15 , RFC1157 , May1990 。
[5]SNMPv2WorkingGroup , Case , J. , McCloghrie , K. , Rose , M.andS.Waldbusser , “ProtocolOperationsforVersion2oftheSimpleNetworkManagementProtocol(SNMPv2)” , RFC1905 , January1996 。
[6]McCloghrie , K.andF.Kastenholz , “EvolutionoftheInterfacesGroupofMIB-II” , RFC1573 , January1994 。
[7]Deering , S.andR.Hinden , Editors , “InternetProtocol , Version6(IPv6)Specification” , RFC2460 , December1998 。
[8]Conta , A.andS.Deering , “InternetControlMessageProtocol(ICMPv6)fortheInternetProtocolVersion6(IPv6)Specification” , RFC2463 , December1998 。
[9]Haskin , D. , andS.Onishi , “ManagementInformationBaseforIPVersion6:TextualConventionsandGeneralGroup” , RFC2465 , December1998 。
6.需要考虑的安全问题
在某些网络环境中 , 认为在这个MIB中定义的某些治理信息是很敏感的 。
因此 , 在这种环境下 , 对收到的SNMP请求和控制访问权限的治理信息进行认证是非常必要的 。
7.作者地址
DimitryHaskin
BayNetworks , Inc.
600TechnologyParkDrive
Billerica , MA01821
EMail:dhaskin@baynetworks.com
SteveOnishi
BayNetworks , Inc.
3FederalStreet
Billerica , MA01821
EMail:sonishi@baynetworks.com
8.完整的版权声明
Copyright(C)TheInternetSociety(2000) 。版权所有 。
本文档及其译文可以拷贝和提供给他人 , 且其衍生物 , 如评论、解释或帮助实施的作品可以全部或部分地定制、拷贝、出版和发布 , 对此我们不加任何限制 , 前提是上述版权声明 , 及本段内容包含在所有的拷贝和派生作品中 。然而 , 本文档本身不答应以任何方式修改 , 例如删除Internet社团或其他Internet组织的版权声明或参考 , 除非是为了开发Internet标准的需要 。即便在这种情况下 , 也需要添加Internet标准中定义的版权声明 , 或者根据需要把他翻译成英语以外的其他语言 。
上述准许的有限许可是永久性的 , 无论是Internet社团以及其继续者或代理者都将不会废止这些许可 。
本文档及其中包含的信息基于“ASIS”提供 , 而且INTERNET社团和IETF拒绝所有授权、表达或影射 , 包括但不限于任何这里使用的消息的授权将不会违反任何版权或者隐含的商业性授权或对特定的合理目的 。